Configuration de OpenWrt sur TP-Link TD-W9980 pour Orange en VDSL2

Voici une procédure pour configurer le modem-routeur TP-Link TD-W9980 en utilisant le port VDSL de façon basique afin d'accéder à Internet et donc sans utiliser la Livebox.

Cette procédure fonctionne aussi si vous êtes en ADSL ou ADSL2+.

Je partirais d'une installation à zéro via un firmware trunk.

Nous n'entrerons pas dans une configuration avancée afin de ne pas se surcharger d'informations, ce qui veut dire que la configuration IPv6 ne sera pas abordée, ni comment utiliser le décodeur TV fournit par Orange.

La configuration se passera uniquement en SSH via les différents fichiers de configuration et vous pouvez tout de même suivre cette procédure si vous avez LuCI d'installé.

  1. Configuration /etc/config/system
  2. Configuration /etc/config/network
  3. Configuration /etc/config/wireless
  4. Et maintenant ?
  5. Références et remerciements

1. /etc/config/system

La première chose à faire est de se connecter au modem-routeur :

[user@local ~]$ ssh root@192.168.1.1

Modification du timezone dans le fichier /etc/config/system afin de pointer sur Europe/Paris :

# […]
option timezone 'CET-1CEST,M3.5.0,M10.5.0/3'
# […]

2. Configuration /etc/config/network

Modification du fichier afin d'avoir Internet par Orange :

[root@serveur ~]$ vi /etc/config/network

Voici le fichier de configuration initial :

config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'

config globals 'globals'
            option ula_prefix 'fd7d:1c69:a962::/48'

config atm-bridge 'atm'
            option vpi '1'
            option vci '32'
            option encaps 'llc'
            option payload 'bridged'

config dsl 'dsl'
            option annex 'a'
            option tone 'av'
            option xfer_mode 'ptm'

config interface 'lan'
            option type 'bridge'
            option ifname 'eth0.1'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            option ip6assign '60'

config device 'lan_dev'
            option name 'eth0.1'
            option macaddr '30:b5:c2:db:4a:7f'

config interface 'wan'
            option ifname 'ptm0'
            option proto 'pppoe'
            option username 'username'
            option password 'password'
            option ipv6 'auto'

config device 'wan_dev'
            option name 'ptm0'
            option macaddr '30:b5:c2:db:4a:80'

config interface 'wan6'
            option ifname 'pppoe-wan'
            option proto 'dhcpv6'

Le fichier de configuration modifié (à adapter notamment au niveau de ula_prefix et de vos identifiants) :

config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'

config globals 'globals'
            option ula_prefix 'fd04:2d69:a37f::/48'

config atm-bridge 'atm'
            option vpi '8'
            option vci '35'
            option encaps 'llc'
            option payload 'bridged'

config dsl 'dsl'
            option annex 'a'
            option tone 'av'
            option xfer_mode 'ptm'
            option firmware '/lib/firmware/lantiq-vrx200-a.bin'

config interface 'lan'
            option type 'bridge'
            option ifname 'eth0.1'
            option proto 'static'
            option ipaddr '192.168.1.1'
            option netmask '255.255.255.0'
            option ip6assign '60'

config interface 'wan'
            option ifname 'ptm0.835'
            option proto 'pppoe'
            option username 'fti/xxxxxxx'
            option password 'xxxxxxx'
            option ipv6 '0'

config interface 'wan6'
            option ifname 'pppoe-wan'
            option proto 'dhcpv6'

config switch
            option name 'switch0'
            option reset '1'
            option enable_vlan '1'

config switch_vlan
            option device 'switch0'
            option vlan '1'
            option ports '0 2 4 5 6t'

Vous devez maintenant redémarrer le modem-routeur :

[root@serveur ~]$ reboot

La connexion à Internet devrait fonctionner :

[user@local ~]$ ssh root@192.168.1.1
[root@serveur ~]$ /etc/init.d/dsl_control status

Qui par exemple chez moi retourne :

ATU-C Vendor ID:                          Broadcom 164.115
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.7.4.3.0.6
API Version:                              4.16.6.3
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.2 (VDSL2)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 743338
Errored seconds (ES):                     Near: 0 / Far: 35
Severely Errored Seconds (SES):           Near: 0 / Far: 4
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 71 / Far: 71
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Fast (0.34 ms) / Up: Fast (0.0 ms)
Data Rate:                                Down: 41.545 Mb/s / Up: 13.689 Mb/s
Line Attenuation (LATN):                  Down: 20.8dB / Up: 31.0dB
Signal Attenuation (SATN):                Down: 20.8dB / Up: 30.9dB
Noise Margin (SNR):                       Down: 8.0dB / Up: 7.8dB
Aggregate Transmit Power (ACTATP):        Down: 6.8dB / Up: 14.5dB
Max. Attainable Data Rate (ATTNDR):       Down: 41.386 Mb/s / Up: 13.663 Mb/s
Line Uptime Seconds:                      504
Line Uptime:                              8m 24s

3. Configuration /etc/config/wireless

Il est nécessaire d'installer le driver kmod-ath9k et d'autres packages, le modem-routeur bénéficie désormais d'Internet et il est possible de télécharger le nécessaire :

[root@serveur ~]$ opkg update
[root@serveur ~]$ opkg install kmod-ath9k hostapd
[root@serveur ~]$ reboot

Suite au redémarrage, le fichier /etc/config/wireless devrait être présent et ressembler à ceci :

config wifi-device radio0
            option type         mac80211
            option channel      11
            option hwmode       11g
            option path         'pci0000:01/0000:01:00.0/0000:02:00.0'
            option htmode       HT20
            # REMOVE THIS LINE TO ENABLE WIFI:
            option disabled     1

config wifi-iface
            option device       radio0
            option network      lan
            option mode         ap
            option ssid         OpenWrt
            option encryption   none

Nous allons le modifier comme ceci, à vous de l'adapter :

config wifi-device 'radio0'
            option type         'mac80211'
            option channel      '11'
            option hwmode       '11g'
            option path         'pci0000:01/0000:01:00.0/0000:02:00.0'
            option htmode       'HT40'
            option country      'FR'

config wifi-iface
            option device       'radio0'
            option network      'lan'
            option mode         'ap'
            option ssid         'mon-ssid'
            option encryption   'psk2+ccmp'
            option key          'mon-password'

Il ne reste plus qu'à appliquer la configuration :

[root@serveur ~]$ wifi

4. Et maintenant ?

Ce guide détaille une configuration basique et minimaliste, vous pouvez aller plus loin, par exemple en modifiant la configuration du firewall, le password root, utiliser un/des serveurs DNS différents de ceux attribués par l'ISP, mais, s'il vous plaît, pas ceux de Google.

Quoi qu'il en soit, il est fortement conseillé de lire le wiki.

En cas de problème durant l'installation, la commande logread -f pourra vous être d'une aide précieuse.

5. Références et remerciements